{"action":"Upgrade uri to 0.12.5 or later.","affected":[{"fixed":"0.12.5","introduced":"0"},{"fixed":"0.13.3","introduced":"0.13.0"},{"fixed":"1.0.4","introduced":"1.0.0"}],"component":"uri","cve_ids":["CVE-2025-61594"],"ecosystem":"RubyGems","epss":0.0056,"exploited":false,"fixed_versions":["0.12.5","0.13.3","1.0.4"],"ghsa_id":"GHSA-j4pr-3wm6-xx2r","id":"tcs_01M5KEKSDZ2FJ8WA9PXFCQNEMK","modified_at":"2026-09-10T03:50:58.735046368Z","published_at":"2025-12-30T21:07:14Z","references":["https://osv.dev/vulnerability/GHSA-j4pr-3wm6-xx2r","https://github.com/ruby/uri/security/advisories/GHSA-j4pr-3wm6-xx2r","https://nvd.nist.gov/vuln/detail/CVE-2025-61594","https://github.com/ruby/uri/commit/20157e3e29b125ff41f1d9662e2e3b1d066f5902","https://github.com/ruby/uri/commit/7e521b2da0833d964aab43019e735aea674e1c2c","https://github.com/ruby/uri/commit/d3116ca66a3b1c97dc7577f9d2d6e353f391cd6a","https://hackerone.com/reports/2957667","https://github.com/advisories/GHSA-22h5-pq3x-2gf2","https://github.com/ruby/uri","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/uri/CVE-2025-61594.yml","https://www.ruby-lang.org/en/news/2025/02/26/security-advisories","https://www.ruby-lang.org/en/news/2025/10/07/uri-cve-2025-61594"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-j4pr-3wm6-xx2r","url":"https://osv.dev/vulnerability/GHSA-j4pr-3wm6-xx2r"}],"summary":"URI Credential Leakage Bypass over CVE-2025-27221"}