{"action":"Upgrade net-ldap to 0.16.0 or later.","affected":[{"fixed":"0.16.0","introduced":"0"}],"component":"net-ldap","cve_ids":["CVE-2017-17718"],"ecosystem":"RubyGems","epss":0.01348,"exploited":false,"fixed_versions":["0.16.0"],"ghsa_id":"GHSA-m7p8-9w66-9frm","id":"tcs_01M5KEM5Q474TQE6BM6YCH1TCS","modified_at":"2023-11-08T03:59:14.647519Z","published_at":"2018-01-06T01:11:34Z","references":["https://osv.dev/vulnerability/GHSA-m7p8-9w66-9frm","https://nvd.nist.gov/vuln/detail/CVE-2017-17718","https://github.com/ruby-ldap/ruby-net-ldap/issues/258","https://github.com/ruby-ldap/ruby-net-ldap/pull/279","https://github.com/ruby-ldap/ruby-net-ldap","http://openwall.com/lists/oss-security/2017/12/17/10"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-m7p8-9w66-9frm","url":"https://osv.dev/vulnerability/GHSA-m7p8-9w66-9frm"}],"summary":"net-ldap Improper Certificate Validation vulnerability"}