{"action":"Upgrade mongrel to 1.0.5 or later.","affected":[{"fixed":"1.0.5","introduced":"1.0.4"},{"fixed":"1.1.3","introduced":"1.1.0"}],"component":"mongrel","cve_ids":["CVE-2007-6612"],"ecosystem":"RubyGems","epss":0.03003,"exploited":false,"fixed_versions":["1.0.5","1.1.3"],"ghsa_id":"GHSA-m7r6-43v2-49vf","id":"tcs_01M5KEM5VZBXQPSKZG9B6NTVB2","modified_at":"2024-12-02T05:47:30.755244Z","published_at":"2022-05-01T18:44:39Z","references":["https://osv.dev/vulnerability/GHSA-m7r6-43v2-49vf","https://nvd.nist.gov/vuln/detail/CVE-2007-6612","https://github.com/mongrel/mongrel","https://lists.apple.com/archives/security-announce/2008//May/msg00001.html","https://web.archive.org/web/20080111034049/http://rubyforge.org/pipermail/mongrel-users/2007-December/004743.html","https://web.archive.org/web/20200301091534/http://www.securityfocus.com/bid/27133"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-m7r6-43v2-49vf","url":"https://osv.dev/vulnerability/GHSA-m7r6-43v2-49vf"}],"summary":"Mongrel vulnerable to directory traversal via double-encoded sequences"}