{"action":"Upgrade rubygems-update to 2.7.6 or later.","affected":[{"fixed":"2.7.6","introduced":"2.2.0"}],"component":"rubygems-update","cve_ids":["CVE-2018-1000076"],"ecosystem":"RubyGems","epss":0.02934,"exploited":false,"fixed_versions":["2.7.6"],"ghsa_id":"GHSA-mc6j-h948-v2p6","id":"tcs_01M5KEM65JXE05CQKZ24TR0GT2","modified_at":"2024-03-11T05:31:35.277732Z","published_at":"2022-05-14T01:01:12Z","references":["https://osv.dev/vulnerability/GHSA-mc6j-h948-v2p6","https://nvd.nist.gov/vuln/detail/CVE-2018-1000076","https://github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7","https://github.com/rubygems/rubygems/commit/f5042b879259b1f1ce95a0c5082622c646376693","https://www.debian.org/security/2018/dsa-4259","https://www.debian.org/security/2018/dsa-4219","https://usn.ubuntu.com/3621-1","https://lists.debian.org/debian-lts-announce/2019/05/msg00028.html","https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html","https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html","https://lists.debian.org/debian-lts-announce/2018/04/msg00001.html","https://lists.debian.org/debian-lts-announce/2018/04/msg00000.html","https://github.com/rubygems/rubygems","https://access.redhat.com/errata/RHSA-2020:0663","https://access.redhat.com/errata/RHSA-2020:0591","https://access.redhat.com/errata/RHSA-2020:0542","https://access.redhat.com/errata/RHSA-2019:2028","https://access.redhat.com/errata/RHSA-2018:3731","https://access.redhat.com/errata/RHSA-2018:3730","https://access.redhat.com/errata/RHSA-2018:3729","http://blog.rubygems.org/2018/02/15/2.7.6-released.html","http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-mc6j-h948-v2p6","url":"https://osv.dev/vulnerability/GHSA-mc6j-h948-v2p6"}],"summary":"RubyGems Improper Verification of Cryptographic Signature vulnerability"}