{"action":"Upgrade cgi to 0.3.5.1 or later.","affected":[{"fixed":"0.3.5.1","introduced":"0"},{"fixed":"0.3.7","introduced":"0.3.6"},{"fixed":"0.4.2","introduced":"0.4.0"}],"component":"cgi","cve_ids":["CVE-2025-27220"],"ecosystem":"RubyGems","epss":0.0076,"exploited":false,"fixed_versions":["0.3.5.1","0.3.7","0.4.2"],"ghsa_id":"GHSA-mhwm-jh88-3gjf","id":"tcs_01M5KEM86X4DVVYK5B2AAYGRZ2","modified_at":"2026-09-10T03:50:56.878678947Z","published_at":"2025-03-03T22:05:08Z","references":["https://osv.dev/vulnerability/GHSA-mhwm-jh88-3gjf","https://nvd.nist.gov/vuln/detail/CVE-2025-27220","https://github.com/ruby/cgi/pull/52","https://github.com/ruby/cgi/pull/53","https://github.com/ruby/cgi/pull/54","https://hackerone.com/reports/2890322","https://github.com/ruby/cgi","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2025-27220.yml","https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html","https://www.cve.org/CVERecord?id=CVE-2025-27220","https://www.ruby-lang.org/en/news/2025/02/26/security-advisories"],"severity":{"label":"medium","score":4},"sources":[{"source":"osv","source_id":"GHSA-mhwm-jh88-3gjf","url":"https://osv.dev/vulnerability/GHSA-mhwm-jh88-3gjf"}],"summary":"CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement"}