{"action":"Upgrade sinatra to 2.0.2 or later.","affected":[{"fixed":"2.0.2","introduced":"2.0.0"}],"component":"sinatra","cve_ids":["CVE-2018-11627"],"ecosystem":"RubyGems","epss":0.02159,"exploited":false,"fixed_versions":["2.0.2"],"ghsa_id":"GHSA-mq35-wqvf-r23c","id":"tcs_01M5KEMAMDX1K61VACGXZXQ8VQ","modified_at":"2024-02-16T08:16:36.186181Z","published_at":"2018-06-05T21:32:06Z","references":["https://osv.dev/vulnerability/GHSA-mq35-wqvf-r23c","https://nvd.nist.gov/vuln/detail/CVE-2018-11627","https://github.com/sinatra/sinatra/issues/1428","https://github.com/sinatra/sinatra/commit/12786867d6faaceaec62c7c2cb5b0e2dc074d71a","https://access.redhat.com/errata/RHSA-2019:0212","https://access.redhat.com/errata/RHSA-2019:0315","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sinatra/CVE-2018-11627.yml","https://github.com/sinatra/sinatra"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-mq35-wqvf-r23c","url":"https://osv.dev/vulnerability/GHSA-mq35-wqvf-r23c"}],"summary":"Sinatra Cross-site Scripting vulnerability"}