{"action":"Upgrade nokogiri to 1.7.2 or later.","affected":[{"fixed":"1.7.2","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2017-5029"],"ecosystem":"RubyGems","epss":0.02159,"exploited":false,"fixed_versions":["1.7.2"],"ghsa_id":"GHSA-pf6m-fxpq-fg8v","id":"tcs_01M5KEMJ2JT53WRDDTKDWBAC49","modified_at":"2024-02-16T08:13:08.873821Z","published_at":"2018-07-31T18:21:29Z","references":["https://osv.dev/vulnerability/GHSA-pf6m-fxpq-fg8v","https://nvd.nist.gov/vuln/detail/CVE-2017-5029","https://github.com/sparklemotion/nokogiri/issues/1634","https://git.gnome.org/browse/libxslt/commit/?id=08ab2774b870de1c7b5a48693df75e8154addae5","https://github.com/advisories/GHSA-pf6m-fxpq-fg8v","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2017-5029.yml","https://github.com/sparklemotion/nokogiri","https://ubuntu.com/security/CVE-2017-5029","https://ubuntu.com/security/notices/USN-3271-1"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-pf6m-fxpq-fg8v","url":"https://osv.dev/vulnerability/GHSA-pf6m-fxpq-fg8v"}],"summary":"Nokogiri implementation of libxslt lacks integer overflow checks"}