{"action":"Upgrade activerecord to 4.2.7.1 or later.","affected":[{"fixed":"4.2.7.1","introduced":"4.2.0"}],"component":"activerecord","cve_ids":["CVE-2016-6317"],"ecosystem":"RubyGems","epss":0.03903,"exploited":false,"fixed_versions":["4.2.7.1"],"ghsa_id":"GHSA-pr3r-4wrp-r2pv","id":"tcs_01M5KEMPGXYXG20NEKM4F46KCH","modified_at":"2024-02-20T05:32:36.742284Z","published_at":"2017-10-24T18:33:35Z","references":["https://osv.dev/vulnerability/GHSA-pr3r-4wrp-r2pv","https://nvd.nist.gov/vuln/detail/CVE-2016-6317","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2016-6317.yml","https://groups.google.com/forum/#!topic/ruby-security-ann/WccgKSKiPZA","https://groups.google.com/forum/#!topic/rubyonrails-security/rgO20zYW33s","http://rhn.redhat.com/errata/RHSA-2016-1855.html","http://weblog.rubyonrails.org/2016/8/11/Rails-5-0-0-1-4-2-7-2-and-3-2-22-3-have-been-released","http://www.openwall.com/lists/oss-security/2016/08/11/4"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-pr3r-4wrp-r2pv","url":"https://osv.dev/vulnerability/GHSA-pr3r-4wrp-r2pv"}],"summary":"ActiveRecord in Ruby on Rails allows database-query bypass"}