{"action":"Upgrade puma to 4.3.8 or later.","affected":[{"fixed":"4.3.8","introduced":"0"},{"fixed":"5.3.1","introduced":"5.0.0"}],"component":"puma","cve_ids":["CVE-2021-29509"],"ecosystem":"RubyGems","epss":0.01599,"exploited":false,"fixed_versions":["4.3.8","5.3.1"],"ghsa_id":"GHSA-q28m-8xjw-8vr5","id":"tcs_01M5KEMR8DDY62JCP74DNSK6NX","modified_at":"2026-07-08T06:00:01.447117147Z","published_at":"2021-05-18T01:27:15Z","references":["https://osv.dev/vulnerability/GHSA-q28m-8xjw-8vr5","https://github.com/puma/puma/security/advisories/GHSA-q28m-8xjw-8vr5","https://nvd.nist.gov/vuln/detail/CVE-2021-29509","https://gist.github.com/nateberkopec/4b3ea5676c0d70cbb37c82d54be25837","https://github.com/puma/puma","https://github.com/puma/puma/security/policy","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2021-29509.yml","https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html","https://rubygems.org/gems/puma","https://security.gentoo.org/glsa/202208-28"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-q28m-8xjw-8vr5","url":"https://osv.dev/vulnerability/GHSA-q28m-8xjw-8vr5"}],"summary":"Puma's Keepalive Connections Causing Denial Of Service"}