{"action":"Upgrade actionpack to 3.0.14 or later.","affected":[{"fixed":"3.0.14","introduced":"3.0.13"},{"fixed":"3.1.6","introduced":"3.1.0"},{"fixed":"3.2.6","introduced":"3.2.0"}],"component":"actionpack","cve_ids":["CVE-2012-2694"],"ecosystem":"RubyGems","epss":0.03887,"exploited":false,"fixed_versions":["3.0.14","3.1.6","3.2.6"],"ghsa_id":"GHSA-q34c-48gc-m9g8","id":"tcs_01M5KEMSDK0VDR5W4ZNV4S147H","modified_at":"2025-01-20T16:44:19.255738Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-q34c-48gc-m9g8","https://nvd.nist.gov/vuln/detail/CVE-2012-2694","https://github.com/rails/rails/commit/2f3bc0467311781ac1ceb2c8c2b09002c8fe143a","https://github.com/rails/rails/commit/c202638225519b5e1a03ebe523b109c948fb0e52","https://github.com/rails/rails","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2012-2694.yml","https://groups.google.com/g/rubyonrails-security/c/jILZ34tAHF4/m/7x0hLH-o0-IJ","https://groups.google.com/group/rubyonrails-security/msg/e2d3a87f2c211def?dmode=source&output=gplain","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00002.html","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00014.html","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00016.html","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00017.html","http://lists.opensuse.org/opensuse-updates/2012-08/msg00046.html","http://rhn.redhat.com/errata/RHSA-2013-0154.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-q34c-48gc-m9g8","url":"https://osv.dev/vulnerability/GHSA-q34c-48gc-m9g8"}],"summary":"actionpack allows remote attackers to bypass database-query restrictions, perform NULL checks via crafted request"}