{"action":"Upgrade excon to 0.71.0 or later.","affected":[{"fixed":"0.71.0","introduced":"0"}],"component":"excon","cve_ids":["CVE-2019-16779"],"ecosystem":"RubyGems","epss":0.01662,"exploited":false,"fixed_versions":["0.71.0"],"ghsa_id":"GHSA-q58g-455p-8vw9","id":"tcs_01M5KEMTNW0YDM00110XDFPM9E","modified_at":"2026-09-10T03:49:25.169523118Z","published_at":"2019-12-16T19:30:17Z","references":["https://osv.dev/vulnerability/GHSA-q58g-455p-8vw9","https://github.com/excon/excon/security/advisories/GHSA-q58g-455p-8vw9","https://nvd.nist.gov/vuln/detail/CVE-2019-16779","https://github.com/excon/excon/commit/ccb57d7a422f020dc74f1de4e8fb505ab46d8a29","https://github.com/excon/excon","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/excon/CVE-2019-16779.yml","https://lists.debian.org/debian-lts-announce/2020/01/msg00015.html","http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00062.html"],"severity":{"label":"medium","score":5.8},"sources":[{"source":"osv","source_id":"GHSA-q58g-455p-8vw9","url":"https://osv.dev/vulnerability/GHSA-q58g-455p-8vw9"}],"summary":"In RubyGem excon, interrupted Persistent Connections May Leak Response Data"}