{"action":"Upgrade nokogiri to 1.6.6.4 or later.","affected":[{"fixed":"1.6.6.4","introduced":"1.6.6.0"}],"component":"nokogiri","cve_ids":["CVE-2015-1819"],"ecosystem":"RubyGems","epss":0.06289,"exploited":false,"fixed_versions":["1.6.6.4"],"ghsa_id":"GHSA-q7wx-62r7-j2x7","id":"tcs_01M5KEMW4ERRXBQHH9HT0CFQ9Z","modified_at":"2024-11-29T05:50:50.325570Z","published_at":"2018-08-08T22:31:12Z","references":["https://osv.dev/vulnerability/GHSA-q7wx-62r7-j2x7","https://nvd.nist.gov/vuln/detail/CVE-2015-1819","https://github.com/sparklemotion/nokogiri/issues/1374","https://git.gnome.org/browse/libxml2/commit/?id=213f1fe0d76d30eaed6e5853057defc43e6df2c9","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2015-1819.yml","https://security.gentoo.org/glsa/201507-08","https://security.gentoo.org/glsa/201701-37","https://support.apple.com/HT206166","https://support.apple.com/HT206167","https://support.apple.com/HT206168","https://support.apple.com/HT206169","http://lists.apple.com/archives/security-announce/2016/Mar/msg00000.html","http://lists.apple.com/archives/security-announce/2016/Mar/msg00001.html","http://lists.apple.com/archives/security-announce/2016/Mar/msg00002.html","http://lists.apple.com/archives/security-announce/2016/Mar/msg00004.html","http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172710.html","http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172943.html","http://lists.opensuse.org/opensuse-updates/2015-12/msg00120.html","http://lists.opensuse.org/opensuse-updates/2016-01/msg00031.html","http://rhn.redhat.com/errata/RHSA-2015-1419.html","http://rhn.redhat.com/errata/RHSA-2015-2550.html","http://www.debian.org/security/2015/dsa-3430","http://www.oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html","http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html","http://www.ubuntu.com/usn/USN-2812-1","http://xmlsoft.org/news.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-q7wx-62r7-j2x7","url":"https://osv.dev/vulnerability/GHSA-q7wx-62r7-j2x7"}],"summary":"Nokogiri vulnerable to libxml XML Entity Expansion"}