{"action":"Upgrade sinatra to 2.2.0 or later.","affected":[{"fixed":"2.2.0","introduced":"0"}],"component":"sinatra","cve_ids":["CVE-2022-29970"],"ecosystem":"RubyGems","epss":0.02137,"exploited":false,"fixed_versions":["2.2.0"],"ghsa_id":"GHSA-qp49-3pvw-x4m5","id":"tcs_01M5KEN06XVG84XDA9Y8AW4NRA","modified_at":"2025-11-04T19:59:48.796726Z","published_at":"2022-05-03T00:00:43Z","references":["https://osv.dev/vulnerability/GHSA-qp49-3pvw-x4m5","https://nvd.nist.gov/vuln/detail/CVE-2022-29970","https://github.com/sinatra/sinatra/pull/1683","https://github.com/sinatra/sinatra/pull/1683/commits/462c3ca1db53ed3cfc394cf5948e9c948ad1c10e","https://github.com/skylightio/skylight-ruby/pull/294","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sinatra/CVE-2022-29970.yml","https://github.com/sinatra/sinatra","https://lists.debian.org/debian-lts-announce/2022/10/msg00034.html","https://lists.debian.org/debian-lts-announce/2024/09/msg00020.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-qp49-3pvw-x4m5","url":"https://osv.dev/vulnerability/GHSA-qp49-3pvw-x4m5"}],"summary":"sinatra does not validate expanded path matches"}