{"action":"Upgrade faye to 1.0.4 or later.","affected":[{"fixed":"1.0.4","introduced":"0.5.0"},{"fixed":"1.1.3","introduced":"1.1.0"},{"fixed":"1.2.5","introduced":"1.2.0"}],"component":"faye","cve_ids":["CVE-2020-11020"],"ecosystem":"RubyGems","epss":0.01573,"exploited":false,"fixed_versions":["1.0.4","1.1.3","1.2.5"],"ghsa_id":"GHSA-qpg4-4w7w-2mq5","id":"tcs_01M5KEN0N4TD8PJRJJ037WRQN7","modified_at":"2026-09-10T03:48:43.957975862Z","published_at":"2020-04-29T17:41:15Z","references":["https://osv.dev/vulnerability/GHSA-qpg4-4w7w-2mq5","https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5","https://nvd.nist.gov/vuln/detail/CVE-2020-11020","https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e","https://github.com/faye/faye","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/faye/CVE-2020-11020.yml"],"severity":{"label":"high","score":8.5},"sources":[{"source":"osv","source_id":"GHSA-qpg4-4w7w-2mq5","url":"https://osv.dev/vulnerability/GHSA-qpg4-4w7w-2mq5"}],"summary":"Authentication and extension bypass in Faye"}