{"action":"Upgrade samlr to 2.6.2 or later.","affected":[{"fixed":"2.6.2","introduced":"0"}],"component":"samlr","cve_ids":["CVE-2018-20857"],"ecosystem":"RubyGems","epss":0.01205,"exploited":false,"fixed_versions":["2.6.2"],"ghsa_id":"GHSA-qpxp-5j56-gg3x","id":"tcs_01M5KEN1A0K40C8R7ZX5HAYWV7","modified_at":"2024-02-16T08:06:00.838759Z","published_at":"2019-07-31T04:22:03Z","references":["https://osv.dev/vulnerability/GHSA-qpxp-5j56-gg3x","https://nvd.nist.gov/vuln/detail/CVE-2018-20857","https://github.com/zendesk/samlr/pull/29","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/samlr/CVE-2018-20857.yml","https://github.com/zendesk/samlr","https://github.com/zendesk/samlr/compare/v2.6.1...v2.6.2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-qpxp-5j56-gg3x","url":"https://osv.dev/vulnerability/GHSA-qpxp-5j56-gg3x"}],"summary":"samlr XML nodes comment attack"}