{"action":"Upgrade nokogiri to 1.10.3 or later.","affected":[{"fixed":"1.10.3","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2019-11068"],"ecosystem":"RubyGems","epss":0.05187,"exploited":false,"fixed_versions":["1.10.3"],"ghsa_id":"GHSA-qxcg-xjjg-66mj","id":"tcs_01M5KEN406Z6YHNW5QZ4W474J6","modified_at":"2026-06-09T10:30:14.618588515Z","published_at":"2022-05-13T01:21:57Z","references":["https://osv.dev/vulnerability/GHSA-qxcg-xjjg-66mj","https://nvd.nist.gov/vuln/detail/CVE-2019-11068","https://github.com/sparklemotion/nokogiri/issues/1892","https://github.com/sparklemotion/nokogiri/pull/1898","https://github.com/sparklemotion/nokogiri/commit/fe034aedcc59b566740567d621843731686676b9","https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html","https://usn.ubuntu.com/3947-2","https://usn.ubuntu.com/3947-1","https://security.netapp.com/advisory/ntap-20191017-0001","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SK4YNISS22MJY22YX5I6V2U63QZAUEHA","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GCOAX2IHUMKCM3ILHTMGLHCDSBTLP2JU","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/36TEYN37XCCKN2XUMRTBBW67BPNMSW4K","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SK4YNISS22MJY22YX5I6V2U63QZAUEHA","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GCOAX2IHUMKCM3ILHTMGLHCDSBTLP2JU","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/36TEYN37XCCKN2XUMRTBBW67BPNMSW4K","https://lists.debian.org/debian-lts-announce/2019/04/msg00016.html","https://gitlab.gnome.org/GNOME/libxslt/commit/e03553605b45c88f0b4b2980adfbbb8f6fca2fd6","https://github.com/sparklemotion/nokogiri/blob/f7aa3b0b29d6fe5fafe93dacd9b96b6b3d16b7ec/CHANGELOG.md?plain=1#L826","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2019-11068.yml","http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00048.html","http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00052.html","http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00053.html","http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00025.html","http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00001.html","http://www.openwall.com/lists/oss-security/2019/04/22/1","http://www.openwall.com/lists/oss-security/2019/04/23/5"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-qxcg-xjjg-66mj","url":"https://osv.dev/vulnerability/GHSA-qxcg-xjjg-66mj"}],"summary":"Nokogiri vulnerable to libxslt protection mechanism bypass"}