{"action":"Upgrade RedCloth to 4.3.0 or later.","affected":[{"fixed":"4.3.0","introduced":"0"}],"component":"RedCloth","cve_ids":["CVE-2012-6684"],"ecosystem":"RubyGems","epss":0.02253,"exploited":false,"fixed_versions":["4.3.0"],"ghsa_id":"GHSA-r23g-3qw4-gfh2","id":"tcs_01M5KEN4JSN9X90JD5XEN20VE1","modified_at":"2024-12-03T06:15:26.753053Z","published_at":"2017-10-24T18:33:37Z","references":["https://osv.dev/vulnerability/GHSA-r23g-3qw4-gfh2","https://nvd.nist.gov/vuln/detail/CVE-2012-6684","https://co3k.org/blog/redcloth-unfixed-xss-en","https://gist.github.com/co3k/75b3cb416c342aa1414c","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/RedCloth/CVE-2012-6684.yml","https://web.archive.org/web/20150128115714/http://jgarber.lighthouseapp.com/projects/13054-redcloth/tickets/243-xss","http://seclists.org/fulldisclosure/2014/Dec/50","http://www.debian.org/security/2015/dsa-3168"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-r23g-3qw4-gfh2","url":"https://osv.dev/vulnerability/GHSA-r23g-3qw4-gfh2"}],"summary":"RedCloth Cross-site Scripting vulnerability"}