{"action":"Upgrade haml to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"haml","cve_ids":["CVE-2017-1002201"],"ecosystem":"RubyGems","epss":0.01452,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-r53w-g4xm-3gc6","id":"tcs_01M5KEN5MZSNH8PGXRC3JPG8XD","modified_at":"2026-09-10T03:48:26.747985965Z","published_at":"2019-10-21T21:59:13Z","references":["https://osv.dev/vulnerability/GHSA-r53w-g4xm-3gc6","https://nvd.nist.gov/vuln/detail/CVE-2017-1002201","https://github.com/haml/haml/commit/18576ae6e9bdcb4303fdbe6b3199869d289d67c2","https://github.com/haml/haml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/haml/CVE-2017-1002201.yml","https://lists.debian.org/debian-lts-announce/2019/11/msg00007.html","https://lists.debian.org/debian-lts-announce/2021/12/msg00028.html","https://security.gentoo.org/glsa/202007-27","https://snyk.io/vuln/SNYK-RUBY-HAML-20362"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-r53w-g4xm-3gc6","url":"https://osv.dev/vulnerability/GHSA-r53w-g4xm-3gc6"}],"summary":"Haml vulnerable to cross-site scripting"}