{"action":"Upgrade resque to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"resque","cve_ids":["CVE-2023-50724"],"ecosystem":"RubyGems","epss":0.00484,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-r8xx-8vm8-x6wj","id":"tcs_01M5KEN77FNCHT7HV8BTJK8DFQ","modified_at":"2026-09-10T03:50:04.605142638Z","published_at":"2023-12-18T19:34:14Z","references":["https://osv.dev/vulnerability/GHSA-r8xx-8vm8-x6wj","https://github.com/resque/resque/security/advisories/GHSA-r8xx-8vm8-x6wj","https://nvd.nist.gov/vuln/detail/CVE-2023-50724","https://github.com/resque/resque/issues/1679","https://github.com/resque/resque/pull/1687","https://github.com/resque/resque/commit/e8e2367fff6990d13109ec2483a456a05fbf9811","https://github.com/resque/resque","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/resque/CVE-2023-50724.yml"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-r8xx-8vm8-x6wj","url":"https://osv.dev/vulnerability/GHSA-r8xx-8vm8-x6wj"}],"summary":"Resque vulnerable to Reflected Cross Site Scripting through pathnames"}