{"action":"Upgrade publify_core to 9.2.10 or later.","affected":[{"fixed":"9.2.10","introduced":"0"}],"component":"publify_core","cve_ids":["CVE-2022-1812"],"ecosystem":"RubyGems","epss":0.30778,"exploited":false,"fixed_versions":["9.2.10"],"ghsa_id":"GHSA-rc42-jghf-vr8f","id":"tcs_01M5KEN8EQGXRASNG9CM2WZ319","modified_at":"2023-12-06T01:01:53.108113Z","published_at":"2023-01-14T15:30:25Z","references":["https://osv.dev/vulnerability/GHSA-rc42-jghf-vr8f","https://nvd.nist.gov/vuln/detail/CVE-2022-1812","https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a","https://github.com/publify/publify_core","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-1812.yml","https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-rc42-jghf-vr8f","url":"https://osv.dev/vulnerability/GHSA-rc42-jghf-vr8f"}],"summary":"Integer overflow in publify_core"}