{"action":"Upgrade rack to 1.4.6 or later.","affected":[{"fixed":"1.5.4","introduced":"1.5.0"},{"fixed":"1.6.2","introduced":"1.6.0"},{"fixed":"1.4.6","introduced":"1.4.0"}],"component":"rack","cve_ids":["CVE-2015-3225"],"ecosystem":"RubyGems","epss":0.07991,"exploited":false,"fixed_versions":["1.5.4","1.6.2","1.4.6"],"ghsa_id":"GHSA-rgr4-9jh5-j4j6","id":"tcs_01M5KEN97PQJRZMQ3BJ4EW6B7X","modified_at":"2024-12-03T06:08:44.186371Z","published_at":"2017-10-24T18:33:36Z","references":["https://osv.dev/vulnerability/GHSA-rgr4-9jh5-j4j6","https://nvd.nist.gov/vuln/detail/CVE-2015-3225","https://github.com/rack/rack","https://github.com/rack/rack/blob/master/HISTORY.md","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2015-3225.yml","https://groups.google.com/forum/#!topic/ruby-security-ann/gcUbICUmKMc","http://lists.fedoraproject.org/pipermail/package-announce/2015-August/164173.html","http://lists.fedoraproject.org/pipermail/package-announce/2015-August/165180.html","http://lists.opensuse.org/opensuse-updates/2015-07/msg00040.html","http://lists.opensuse.org/opensuse-updates/2015-07/msg00043.html","http://lists.opensuse.org/opensuse-updates/2015-07/msg00044.html","http://openwall.com/lists/oss-security/2015/06/16/14","http://rhn.redhat.com/errata/RHSA-2015-2290.html","http://www.debian.org/security/2015/dsa-3322"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-rgr4-9jh5-j4j6","url":"https://osv.dev/vulnerability/GHSA-rgr4-9jh5-j4j6"}],"summary":"Rack vulnerable to Denial of Service via large parameter depth request"}