{"action":"Upgrade secure_headers to 7.3.0 or later.","affected":[{"fixed":"7.3.0","introduced":"0"}],"component":"secure_headers","cve_ids":["CVE-2026-54163"],"ecosystem":"RubyGems","epss":0.00214,"exploited":false,"fixed_versions":["7.3.0"],"ghsa_id":"GHSA-rqq5-2gf9-4w4q","id":"tcs_01M5KENB0V84AG81NJMQ31N7YS","modified_at":"2026-07-10T20:56:35.922897Z","published_at":"2026-07-10T20:37:15Z","references":["https://osv.dev/vulnerability/GHSA-rqq5-2gf9-4w4q","https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q","https://github.com/github/secure_headers","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/secure_headers/CVE-2026-54163.yml","https://www.cve.org/CVERecord/SearchResults?query=CVE-2026-54163"],"severity":{"label":"medium","score":4.7},"sources":[{"source":"osv","source_id":"GHSA-rqq5-2gf9-4w4q","url":"https://osv.dev/vulnerability/GHSA-rqq5-2gf9-4w4q"}],"summary":"Secure Headers: CSP directive injection via sandbox, plugin_types, and report_to when given untrusted input"}