{"action":"Upgrade rack to 2.0.9.2 or later.","affected":[{"fixed":"2.0.9.2","introduced":"2.0.0"},{"fixed":"2.1.4.2","introduced":"2.1.0.0"},{"fixed":"2.2.6.1","introduced":"2.2.0.0"},{"fixed":"3.0.4.1","introduced":"3.0.0.0"}],"component":"rack","cve_ids":["CVE-2022-44572"],"ecosystem":"RubyGems","epss":0.01617,"exploited":false,"fixed_versions":["2.0.9.2","2.1.4.2","2.2.6.1","3.0.4.1"],"ghsa_id":"GHSA-rqv2-275x-2jq5","id":"tcs_01M5KENB5RGRYRN52ZJ1SDPGTQ","modified_at":"2024-12-01T05:36:04.725362Z","published_at":"2023-01-18T18:19:21Z","references":["https://osv.dev/vulnerability/GHSA-rqv2-275x-2jq5","https://nvd.nist.gov/vuln/detail/CVE-2022-44572","https://hackerone.com/reports/1639882","https://github.com/rack/rack","https://github.com/rack/rack/releases/tag/v3.0.4.1","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-44572.yml","https://www.debian.org/security/2023/dsa-5530"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-rqv2-275x-2jq5","url":"https://osv.dev/vulnerability/GHSA-rqv2-275x-2jq5"}],"summary":"Denial of service via multipart parsing in Rack"}