{"action":"Upgrade rails-html-sanitizer to 1.4.4 or later.","affected":[{"fixed":"1.4.4","introduced":"0"}],"component":"rails-html-sanitizer","cve_ids":["CVE-2022-23520"],"ecosystem":"RubyGems","epss":0.01185,"exploited":false,"fixed_versions":["1.4.4"],"ghsa_id":"GHSA-rrfc-7g8p-99q8","id":"tcs_01M5KENBKQNVPQCYVJWG4SJ9XC","modified_at":"2025-11-04T17:00:59.503348Z","published_at":"2022-12-13T17:51:40Z","references":["https://osv.dev/vulnerability/GHSA-rrfc-7g8p-99q8","https://github.com/rails/rails-html-sanitizer/security/advisories/GHSA-rrfc-7g8p-99q8","https://nvd.nist.gov/vuln/detail/CVE-2022-23520","https://hackerone.com/reports/1654310","https://github.com/rails/rails-html-sanitizer","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails-html-sanitizer/CVE-2022-23520.yml","https://lists.debian.org/debian-lts-announce/2023/09/msg00012.html","https://lists.debian.org/debian-lts-announce/2024/09/msg00045.html"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-rrfc-7g8p-99q8","url":"https://osv.dev/vulnerability/GHSA-rrfc-7g8p-99q8"}],"summary":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer"}