{"action":"Upgrade rails to 1.1.6 or later.","affected":[{"fixed":"1.1.6","introduced":"1.1.0"}],"component":"rails","cve_ids":["CVE-2006-4111"],"ecosystem":"RubyGems","epss":0.02334,"exploited":false,"fixed_versions":["1.1.6"],"ghsa_id":"GHSA-rvpq-5xqx-pfpp","id":"tcs_01M5KENC4871RGFRQ7FP3Q4CRT","modified_at":"2025-04-03T14:58:34.698394Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-rvpq-5xqx-pfpp","https://nvd.nist.gov/vuln/detail/CVE-2006-4111","https://github.com/presidentbeef/rails-security-history/blob/master/vulnerabilities.md","https://github.com/rails/rails","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2006-4111.yml","https://web.archive.org/web/20200301174340/http://www.securityfocus.com/bid/19454","https://web.archive.org/web/20200808083046/http://securitytracker.com/id?1016673","http://blog.koehntopp.de/archives/1367-Ruby-On-Rails-Mandatory-Mystery-Patch.html","http://weblog.rubyonrails.org/2006/8/9/rails-1-1-5-mandatory-security-patch-and-other-tidbits","http://www.gentoo.org/security/en/glsa/glsa-200608-20.xml","http://www.novell.com/linux/security/advisories/2006_21_sr.html"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-rvpq-5xqx-pfpp","url":"https://osv.dev/vulnerability/GHSA-rvpq-5xqx-pfpp"}],"summary":"Ruby on Rails vulnerable to code injection"}