{"action":"Upgrade rack-ssl to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"rack-ssl","cve_ids":["CVE-2014-2538"],"ecosystem":"RubyGems","epss":0.0219,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-v3rr-cph9-2g2q","id":"tcs_01M5KENDQ94STST4JX0ZZ1N1RD","modified_at":"2025-04-13T23:39:16.021465Z","published_at":"2017-10-24T18:33:36Z","references":["https://osv.dev/vulnerability/GHSA-v3rr-cph9-2g2q","https://nvd.nist.gov/vuln/detail/CVE-2014-2538","https://github.com/josh/rack-ssl/commit/9d7d7300b907e496db68d89d07fbc2e0df0b487b","https://github.com/josh/rack-ssl","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack-ssl/CVE-2014-2538.yml","https://web.archive.org/web/20140524002455/http://secunia.com/advisories/57466","https://web.archive.org/web/20200228185649/http://www.securityfocus.com/bid/66314","http://lists.opensuse.org/opensuse-updates/2014-04/msg00032.html","http://www.openwall.com/lists/oss-security/2014/03/19/20"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-v3rr-cph9-2g2q","url":"https://osv.dev/vulnerability/GHSA-v3rr-cph9-2g2q"}],"summary":"rack-ssl Cross-site Scripting vulnerability"}