{"action":"Upgrade rexml to 3.2.7 or later.","affected":[{"fixed":"3.2.7","introduced":"0"}],"component":"rexml","cve_ids":["CVE-2024-35176"],"ecosystem":"RubyGems","epss":0.02064,"exploited":false,"fixed_versions":["3.2.7"],"ghsa_id":"GHSA-vg3r-rm7w-2xgh","id":"tcs_01M5KENJB9V08GXKT0517CCQBD","modified_at":"2026-09-10T03:50:14.352438622Z","published_at":"2024-05-16T17:44:04Z","references":["https://osv.dev/vulnerability/GHSA-vg3r-rm7w-2xgh","https://github.com/ruby/rexml/security/advisories/GHSA-vg3r-rm7w-2xgh","https://nvd.nist.gov/vuln/detail/CVE-2024-35176","https://github.com/ruby/rexml/commit/4325835f92f3f142ebd91a3fdba4e1f1ab7f1cfb","https://github.com/ruby/rexml","https://lists.debian.org/debian-lts-announce/2025/01/msg00011.html","https://security.netapp.com/advisory/ntap-20250306-0001","https://www.ruby-lang.org/en/news/2024/05/16/dos-rexml-cve-2024-35176"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-vg3r-rm7w-2xgh","url":"https://osv.dev/vulnerability/GHSA-vg3r-rm7w-2xgh"}],"summary":"REXML contains a denial of service vulnerability"}