{"action":"Upgrade sfpagent to 0.4.15 or later.","affected":[{"fixed":"0.4.15","introduced":"0"}],"component":"sfpagent","cve_ids":["CVE-2014-2888"],"ecosystem":"RubyGems","epss":0.02188,"exploited":false,"fixed_versions":["0.4.15"],"ghsa_id":"GHSA-vm28-mrm7-fpjq","id":"tcs_01M5KENJNZXHPEMXSFTKY24RQN","modified_at":"2025-04-13T23:37:47.835773Z","published_at":"2017-10-24T18:33:36Z","references":["https://osv.dev/vulnerability/GHSA-vm28-mrm7-fpjq","https://nvd.nist.gov/vuln/detail/CVE-2014-2888","https://github.com/herry13/sfpagent","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sfpagent/CVE-2014-2888.yml","https://web.archive.org/web/20201029141944/http://www.vapid.dhs.org/advisories/spfagent-remotecmd.html","http://seclists.org/fulldisclosure/2014/Apr/243","http://www.openwall.com/lists/oss-security/2014/04/16/1","http://www.openwall.com/lists/oss-security/2014/04/18/4"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-vm28-mrm7-fpjq","url":"https://osv.dev/vulnerability/GHSA-vm28-mrm7-fpjq"}],"summary":"sfpagent Command Injection vulnerability"}