{"action":"Upgrade nokogiri to 1.10.5 or later.","affected":[{"fixed":"1.10.5","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2019-5815"],"ecosystem":"RubyGems","epss":0.01817,"exploited":false,"fixed_versions":["1.10.5"],"ghsa_id":"GHSA-vmfx-gcfq-wvm2","id":"tcs_01M5KENKDCA9XFH8SW4XVHF0QN","modified_at":"2024-02-16T08:22:10.222527Z","published_at":"2022-05-24T17:03:17Z","references":["https://osv.dev/vulnerability/GHSA-vmfx-gcfq-wvm2","https://nvd.nist.gov/vuln/detail/CVE-2019-5815","https://github.com/sparklemotion/nokogiri/issues/2630","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2019-5815.yml","https://github.com/sparklemotion/nokogiri","https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b","https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-vmfx-gcfq-wvm2","url":"https://osv.dev/vulnerability/GHSA-vmfx-gcfq-wvm2"}],"summary":"Nokogiri implementation of libxslt vulnerable to heap corruption"}