{"action":"Upgrade apollo_upload_server to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"apollo_upload_server","cve_ids":["CVE-2021-39880"],"ecosystem":"RubyGems","epss":0.02066,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-w6pv-c757-6rgr","id":"tcs_01M5KENTGCTRD7P5JGVP1PDBAA","modified_at":"2024-12-03T05:56:54.407077Z","published_at":"2022-05-24T19:16:32Z","references":["https://osv.dev/vulnerability/GHSA-w6pv-c757-6rgr","https://nvd.nist.gov/vuln/detail/CVE-2021-39880","https://github.com/jetruby/apollo_upload_server-ruby/pull/44","https://github.com/jetruby/apollo_upload_server-ruby/commit/b0582c1a3e458eee3c994fb38278bd0221f20486","https://hackerone.com/reports/1181284","https://github.com/jetruby/apollo_upload_server-ruby","https://github.com/jetruby/apollo_upload_server-ruby/releases/tag/2.1.0","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/apollo_upload_server/CVE-2021-39880.yml","https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39880.json","https://gitlab.com/gitlab-org/gitlab/-/issues/330561","https://gitlab.com/gitlab-org/gitlab/-/issues/330561#note_642879964","https://vuldb.com/?id.183842"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-w6pv-c757-6rgr","url":"https://osv.dev/vulnerability/GHSA-w6pv-c757-6rgr"}],"summary":"apollo_upload_server has Denial of Service vulnerability"}