{"action":"Upgrade openc3 to 6.10.2 or later.","affected":[{"fixed":"6.10.2","introduced":"5.0.6"}],"component":"openc3","cve_ids":["CVE-2025-68271"],"ecosystem":"RubyGems","epss":0.00642,"exploited":false,"fixed_versions":["6.10.2"],"ghsa_id":"GHSA-w757-4qv9-mghp","id":"tcs_01M5KENVJ4AY74QXM3H0KTT6V3","modified_at":"2026-02-03T02:56:30.118719Z","published_at":"2026-01-13T19:01:49Z","references":["https://osv.dev/vulnerability/GHSA-w757-4qv9-mghp","https://github.com/OpenC3/cosmos/security/advisories/GHSA-w757-4qv9-mghp","https://nvd.nist.gov/vuln/detail/CVE-2025-68271","https://github.com/OpenC3/cosmos/commit/01e9fbc5e66e9a2500b71a75a44775dd1fc2d1de","https://github.com/OpenC3/cosmos","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/openc3/CVE-2025-68271.yml"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"GHSA-w757-4qv9-mghp","url":"https://osv.dev/vulnerability/GHSA-w757-4qv9-mghp"}],"summary":"openc3-api Vulnerable to Unauthenticated Remote Code Execution"}