{"action":"Upgrade delayed_job_web to 1.4.2 or later.","affected":[{"fixed":"1.4.2","introduced":"1.2.9"}],"component":"delayed_job_web","cve_ids":["CVE-2017-12097"],"ecosystem":"RubyGems","epss":0.01012,"exploited":false,"fixed_versions":["1.4.2"],"ghsa_id":"GHSA-w7q9-xr2x-wh7x","id":"tcs_01M5KENVWFJ3GGJ54DCXF9WCCW","modified_at":"2024-02-16T08:18:56.245257Z","published_at":"2018-03-05T19:06:00Z","references":["https://osv.dev/vulnerability/GHSA-w7q9-xr2x-wh7x","https://nvd.nist.gov/vuln/detail/CVE-2017-12097","https://github.com/ejschmitt/delayed_job_web/commit/6bcb10e61ea2b9a44ffa16be8536dff46ad51449","https://github.com/ejschmitt/delayed_job_web","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/delayed_job_web/CVE-2017-12097.yml","https://rubygems.org/gems/delayed_job_web/versions/1.4","https://web.archive.org/web/20200227132840/http://www.securityfocus.com/bid/102484","https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0449"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-w7q9-xr2x-wh7x","url":"https://osv.dev/vulnerability/GHSA-w7q9-xr2x-wh7x"}],"summary":"delayed_job_web Cross-site Scripting vulnerability"}