{"action":"Upgrade secure_headers to 3.9.0 or later.","affected":[{"fixed":"6.3.0","introduced":"6.0.0"},{"fixed":"5.2.0","introduced":"5.0.0"},{"fixed":"3.9.0","introduced":"0"}],"component":"secure_headers","cve_ids":["CVE-2020-5216"],"ecosystem":"RubyGems","epss":0.01209,"exploited":false,"fixed_versions":["6.3.0","5.2.0","3.9.0"],"ghsa_id":"GHSA-w978-rmpf-qmwg","id":"tcs_01M5KENW6FKNAXNHH4BEM5PH5W","modified_at":"2026-07-08T05:59:41.636653462Z","published_at":"2020-01-23T02:27:53Z","references":["https://osv.dev/vulnerability/GHSA-w978-rmpf-qmwg","https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg","https://nvd.nist.gov/vuln/detail/CVE-2020-5216","https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/secure_headers/CVE-2020-5216.yml","https://github.com/twitter/secure_headers"],"severity":{"label":"medium","score":4.4},"sources":[{"source":"osv","source_id":"GHSA-w978-rmpf-qmwg","url":"https://osv.dev/vulnerability/GHSA-w978-rmpf-qmwg"}],"summary":"Limited header injection when using dynamic overrides with user input in RubyGems secure_headers"}