{"action":"Upgrade jquery-ui-rails to 4.0.0 or later.","affected":[{"fixed":"4.0.0","introduced":"0"}],"component":"jquery-ui-rails","cve_ids":["CVE-2010-5312"],"ecosystem":"RubyGems","epss":0.18351,"exploited":false,"fixed_versions":["4.0.0"],"ghsa_id":"GHSA-wcm2-9c89-wmfm","id":"tcs_01M5KENWZJT41Z1TY37JKQ1DAF","modified_at":"2025-04-14T22:27:41.280021Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-wcm2-9c89-wmfm","https://nvd.nist.gov/vuln/detail/CVE-2010-5312","https://github.com/jquery/jquery-ui/commit/7e9060c109b928769a664dbcc2c17bd21231b6f3","https://www.drupal.org/sa-core-2022-002","https://web.archive.org/web/20170316161850/http://www.securitytracker.com/id/1037035","https://web.archive.org/web/20150316023043/http://www.securityfocus.com/bid/71106","https://security.netapp.com/advisory/ntap-20190416-0007","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3","https://lists.debian.org/debian-lts-announce/2022/01/msg00014.html","https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E","https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc%40%3Cissues.drill.apache.org%3E","https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E","https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E","https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E","https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jquery-ui-rails/CVE-2010-5312.yml","https://github.com/jquery/jquery-ui","https://exchange.xforce.ibmcloud.com/vulnerabilities/98696","http://bugs.jqueryui.com/ticket/6016","http://rhn.redhat.com/errata/RHSA-2015-0442.html","http://rhn.redhat.com/errata/RHSA-2015-1462.html","http://seclists.org/oss-sec/2014/q4/613","http://seclists.org/oss-sec/2014/q4/616","http://www.debian.org/security/2015/dsa-3249","http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-wcm2-9c89-wmfm#RubyGems/jquery-ui-rails","url":"https://osv.dev/vulnerability/GHSA-wcm2-9c89-wmfm"}],"summary":"Cross-site Scripting in jquery-ui"}