{"action":"Upgrade view_component to 2.83.0 or later.","affected":[{"fixed":"3.9.0","introduced":"3.0.0"},{"fixed":"2.83.0","introduced":"0"}],"component":"view_component","cve_ids":["CVE-2024-21636"],"ecosystem":"RubyGems","epss":0.00495,"exploited":false,"fixed_versions":["3.9.0","2.83.0"],"ghsa_id":"GHSA-wf2x-8w6j-qw37","id":"tcs_01M5KENX4DS6DWAVMVS2QJ8320","modified_at":"2026-09-10T03:49:24.818621008Z","published_at":"2024-01-04T21:54:34Z","references":["https://osv.dev/vulnerability/GHSA-wf2x-8w6j-qw37","https://github.com/ViewComponent/view_component/security/advisories/GHSA-wf2x-8w6j-qw37","https://nvd.nist.gov/vuln/detail/CVE-2024-21636","https://github.com/ViewComponent/view_component/pull/1950","https://github.com/ViewComponent/view_component/pull/1962","https://github.com/ViewComponent/view_component/commit/0d26944a8d2730ea40e60eae23d70684483e5017","https://github.com/ViewComponent/view_component/commit/c43d8bafa7117cbce479669a423ab266de150697","https://github.com/ViewComponent/view_component","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/view_component/CVE-2024-21636.yml"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-wf2x-8w6j-qw37","url":"https://osv.dev/vulnerability/GHSA-wf2x-8w6j-qw37"}],"summary":"view_component Cross-site Scripting vulnerability"}