{"action":"Upgrade rack to 2.0.9.1 or later.","affected":[{"fixed":"2.0.9.1","introduced":"0"},{"fixed":"2.1.4.1","introduced":"2.1"},{"fixed":"2.2.3.1","introduced":"2.2"}],"component":"rack","cve_ids":["CVE-2022-30123"],"ecosystem":"RubyGems","epss":0.01955,"exploited":false,"fixed_versions":["2.0.9.1","2.1.4.1","2.2.3.1"],"ghsa_id":"GHSA-wq4h-7r42-5hrr","id":"tcs_01M5KEP092WVQGRW90AP8Y4EA9","modified_at":"2024-02-18T05:41:38.830363Z","published_at":"2022-05-27T16:36:51Z","references":["https://osv.dev/vulnerability/GHSA-wq4h-7r42-5hrr","https://nvd.nist.gov/vuln/detail/CVE-2022-30123","https://github.com/rack/rack/commit/b426cc224908ec6ed6eb8729325392b048215d88","https://discuss.rubyonrails.org/t/cve-2022-30123-possible-shell-escape-sequence-injection-vulnerability-in-rack/80728","https://github.com/rack/rack","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-30123.yml","https://groups.google.com/g/ruby-security-ann/c/LWB10kWzag8","https://security.gentoo.org/glsa/202310-18","https://security.netapp.com/advisory/ntap-20231208-0011","https://www.debian.org/security/2023/dsa-5530"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"GHSA-wq4h-7r42-5hrr","url":"https://osv.dev/vulnerability/GHSA-wq4h-7r42-5hrr"}],"summary":"Possible shell escape sequence injection vulnerability in Rack"}