{"action":"Upgrade ruby-saml to 1.7.0 or later.","affected":[{"fixed":"1.7.0","introduced":"0"}],"component":"ruby-saml","cve_ids":["CVE-2017-11428"],"ecosystem":"RubyGems","epss":0.02464,"exploited":false,"fixed_versions":["1.7.0"],"ghsa_id":"GHSA-x2fr-v8wf-8wwv","id":"tcs_01M5KEP3DANJ6YMVS46MTNW4ZN","modified_at":"2023-11-08T03:58:49.357834Z","published_at":"2019-07-05T21:11:35Z","references":["https://osv.dev/vulnerability/GHSA-x2fr-v8wf-8wwv","https://nvd.nist.gov/vuln/detail/CVE-2017-11428","https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations","https://www.kb.cert.org/vuls/id/475445"],"severity":{"label":"high","score":7.7},"sources":[{"source":"osv","source_id":"GHSA-x2fr-v8wf-8wwv","url":"https://osv.dev/vulnerability/GHSA-x2fr-v8wf-8wwv"}],"summary":"Ruby-SAML Improper Authentication vulnerability"}