{"action":"Upgrade ruby-saml to 1.18.0 or later.","affected":[{"fixed":"1.18.0","introduced":"0"}],"component":"ruby-saml","cve_ids":["CVE-2025-66568"],"ecosystem":"RubyGems","epss":0.0025,"exploited":false,"fixed_versions":["1.18.0"],"ghsa_id":"GHSA-x4h9-gwv3-r4m4","id":"tcs_01M5KEP507W7ZXD0N9QZ0KYF78","modified_at":"2025-12-12T22:21:53.601998Z","published_at":"2025-12-08T22:03:19Z","references":["https://osv.dev/vulnerability/GHSA-x4h9-gwv3-r4m4","https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-x4h9-gwv3-r4m4","https://nvd.nist.gov/vuln/detail/CVE-2025-66568","https://github.com/SAML-Toolkits/ruby-saml/commit/acac9e9cc0b9a507882c614f25d41f8b47be349a","https://github.com/SAML-Toolkits/ruby-saml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-66568.yml"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-x4h9-gwv3-r4m4","url":"https://osv.dev/vulnerability/GHSA-x4h9-gwv3-r4m4"},{"source":"nvd","source_id":"CVE-2025-66568","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-66568"}],"summary":"Ruby-saml allows a Libxml2 Canonicalization error to bypass Digest/Signature validation"}