{"action":"Upgrade nokogiri to 1.15.6 or later.","affected":[{"fixed":"1.16.2","introduced":"1.16.0"},{"fixed":"1.15.6","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2024-58378"],"ecosystem":"RubyGems","exploited":false,"fixed_versions":["1.16.2","1.15.6"],"ghsa_id":"GHSA-xc9x-jj77-9p9j","id":"tcs_01M5KEP7PY4BGE7ARADC91XJ5B","modified_at":"2026-08-27T04:10:44.538377098Z","published_at":"2024-02-05T20:22:56Z","references":["https://osv.dev/vulnerability/GHSA-xc9x-jj77-9p9j","https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-xc9x-jj77-9p9j","https://nvd.nist.gov/vuln/detail/CVE-2024-25062","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/GHSA-xc9x-jj77-9p9j.yml","https://github.com/sparklemotion/nokogiri","https://github.com/sparklemotion/nokogiri/discussions/3146","https://gitlab.gnome.org/GNOME/libxml2/-/commit/92721970","https://gitlab.gnome.org/GNOME/libxml2/-/issues/604","https://gitlab.gnome.org/GNOME/libxml2/-/releases/v2.12.5"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-xc9x-jj77-9p9j","url":"https://osv.dev/vulnerability/GHSA-xc9x-jj77-9p9j"}],"summary":"Nokogiri update packaged libxml2 to v2.12.5 to resolve CVE-2024-25062"}