{"action":"Upgrade yard to 0.9.20 or later.","affected":[{"fixed":"0.9.20","introduced":"0"}],"component":"yard","cve_ids":["CVE-2019-1020001"],"ecosystem":"RubyGems","epss":0.02334,"exploited":false,"fixed_versions":["0.9.20"],"ghsa_id":"GHSA-xfhh-rx56-rxcr","id":"tcs_01M5KEP84GE95G188SCN4AGPNQ","modified_at":"2026-09-10T03:48:25.196120356Z","published_at":"2019-07-02T15:28:38Z","references":["https://osv.dev/vulnerability/GHSA-xfhh-rx56-rxcr","https://github.com/lsegal/yard/security/advisories/GHSA-xfhh-rx56-rxcr","https://nvd.nist.gov/vuln/detail/CVE-2019-1020001","https://github.com/advisories/GHSA-xfhh-rx56-rxcr","https://lists.debian.org/debian-lts-announce/2024/03/msg00006.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-xfhh-rx56-rxcr","url":"https://osv.dev/vulnerability/GHSA-xfhh-rx56-rxcr"}],"summary":"Path Traversal vulnerability that affects yard"}