{"action":"Upgrade gtk2 to 0.17.0 or later.","affected":[{"fixed":"0.17.0","introduced":"0"}],"component":"gtk2","cve_ids":["CVE-2007-6183"],"ecosystem":"RubyGems","epss":0.0338,"exploited":false,"fixed_versions":["0.17.0"],"ghsa_id":"GHSA-xgj6-pgrm-x4r2","id":"tcs_01M5KEP89B81G1GZB3XSQ41WZJ","modified_at":"2023-11-08T03:56:49.291314Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-xgj6-pgrm-x4r2","https://nvd.nist.gov/vuln/detail/CVE-2007-6183","https://bugzilla.redhat.com/show_bug.cgi?id=402871","https://exchange.xforce.ibmcloud.com/vulnerabilities/38757","https://web.archive.org/web/20200228174159/http://www.securityfocus.com/bid/26616","https://web.archive.org/web/20201207224244/https://www.securityfocus.com/archive/1/484240/100/0/threaded","https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00214.html","https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00251.html","http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=453689","http://bugs.gentoo.org/show_bug.cgi?id=200623","http://em386.blogspot.com/2007/11/your-favorite-better-than-c-scripting.html","http://security.gentoo.org/glsa/glsa-200712-09.xml","http://securityreason.com/securityalert/3407","http://www.debian.org/security/2007/dsa-1431","http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2008:033/?name=MDVSA-2008:033"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-xgj6-pgrm-x4r2","url":"https://osv.dev/vulnerability/GHSA-xgj6-pgrm-x4r2"}],"summary":"gtk2 vulnerable to Use of Externally-Controlled Format String"}