{"action":"Upgrade jruby-openssl to 0.6 or later.","affected":[{"fixed":"0.6","introduced":"0"}],"component":"jruby-openssl","cve_ids":["CVE-2009-4123"],"ecosystem":"RubyGems","epss":0.006,"exploited":false,"fixed_versions":["0.6"],"ghsa_id":"GHSA-xgv7-pqqh-h2w9","id":"tcs_01M5KEP8KAKW52277WEJWDW8MK","modified_at":"2024-02-16T08:07:53.674871Z","published_at":"2023-01-19T17:51:27Z","references":["https://osv.dev/vulnerability/GHSA-xgv7-pqqh-h2w9","https://nvd.nist.gov/vuln/detail/CVE-2009-4123","https://github.com/advisories/GHSA-xgv7-pqqh-h2w9","https://github.com/jruby/jruby-openssl","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jruby-openssl/CVE-2009-4123.yml","https://web.archive.org/web/20101213091125/http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl","http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-xgv7-pqqh-h2w9","url":"https://osv.dev/vulnerability/GHSA-xgv7-pqqh-h2w9"}],"summary":"jruby-openssl gem for JRuby fails to do proper certificate validation"}