{"action":"Upgrade rack to 2.2.8.1 or later.","affected":[{"fixed":"3.0.9.1","introduced":"3.0.0"},{"fixed":"2.2.8.1","introduced":"1.3.0"}],"component":"rack","cve_ids":["CVE-2024-26141"],"ecosystem":"RubyGems","epss":0.01612,"exploited":false,"fixed_versions":["3.0.9.1","2.2.8.1"],"ghsa_id":"GHSA-xj5v-6v4g-jfw6","id":"tcs_01M5KEP9DN09XFGNHJXX51N8H9","modified_at":"2026-09-10T03:50:00.330149102Z","published_at":"2024-02-28T22:57:12Z","references":["https://osv.dev/vulnerability/GHSA-xj5v-6v4g-jfw6","https://github.com/rack/rack/security/advisories/GHSA-xj5v-6v4g-jfw6","https://nvd.nist.gov/vuln/detail/CVE-2024-26141","https://github.com/rack/rack/commit/4849132bef471adb21131980df745f4bb84de2d9","https://github.com/rack/rack/commit/62457686b26d33a15a254c7768c2076e8e02b48b","https://discuss.rubyonrails.org/t/possible-dos-vulnerability-with-range-header-in-rack/84944","https://github.com/rack/rack","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26141.yml"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-xj5v-6v4g-jfw6","url":"https://osv.dev/vulnerability/GHSA-xj5v-6v4g-jfw6"}],"summary":"Rack has possible DoS Vulnerability with Range Header"}