{"action":"Upgrade activerecord to 3.2.22.1 or later.","affected":[{"fixed":"3.2.22.1","introduced":"3.1.0"},{"fixed":"4.1.14.1","introduced":"4.0.0"},{"fixed":"4.2.5.1","introduced":"4.2.0"},{"fixed":"5.0.0.beta1.1","introduced":"5.0.0.beta1"}],"component":"activerecord","cve_ids":["CVE-2015-7577"],"ecosystem":"RubyGems","epss":0.0425,"exploited":false,"fixed_versions":["3.2.22.1","4.1.14.1","4.2.5.1","5.0.0.beta1.1"],"ghsa_id":"GHSA-xrr6-3pc4-m447","id":"tcs_01M5KEPB7ZSH0ZPNZZ61Z1R1WS","modified_at":"2024-02-16T08:03:42.644888Z","published_at":"2017-10-24T18:33:36Z","references":["https://osv.dev/vulnerability/GHSA-xrr6-3pc4-m447","https://nvd.nist.gov/vuln/detail/CVE-2015-7577","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2015-7577.yml","https://groups.google.com/forum/#!topic/rubyonrails-security/cawsWcQ6c8g","http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178041.html","http://lists.fedoraproject.org/pipermail/package-announce/2016-February/178065.html","http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00053.html","http://lists.opensuse.org/opensuse-updates/2016-02/msg00034.html","http://lists.opensuse.org/opensuse-updates/2016-02/msg00043.html","http://rhn.redhat.com/errata/RHSA-2016-0296.html","http://www.debian.org/security/2016/dsa-3464","http://www.openwall.com/lists/oss-security/2016/01/25/10"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-xrr6-3pc4-m447","url":"https://osv.dev/vulnerability/GHSA-xrr6-3pc4-m447"}],"summary":"Active Record Improper Access Control"}