{"action":"Upgrade fuel-vm to 0.59.3 or later.","affected":[{"fixed":"0.59.3","introduced":"0"},{"fixed":"0.60.1","introduced":"0.60.0"}],"component":"fuel-vm","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.59.3","0.60.1"],"ghsa_id":"GHSA-2pgj-5cv2-6xxw","id":"tcs_01M5KERF0A23RT8KNRPY8952Q3","modified_at":"2025-10-08T12:43:30Z","published_at":"2025-10-08T12:43:30Z","references":["https://osv.dev/vulnerability/GHSA-2pgj-5cv2-6xxw","https://github.com/FuelLabs/fuel-vm/security/advisories/GHSA-2pgj-5cv2-6xxw","https://github.com/FuelLabs/fuel-vm/pull/941","https://github.com/FuelLabs/fuel-vm/commit/9c97c2bf782626b35ba48e154f210f91c847a513","https://github.com/FuelLabs/fuel-vm"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-2pgj-5cv2-6xxw","url":"https://osv.dev/vulnerability/GHSA-2pgj-5cv2-6xxw"}],"summary":"FuelVM is vulnerable to heap memory allocation re-use bug"}