{"action":"Upgrade psd-tools to 1.9.4 or later.","affected":[{"fixed":"1.9.4","introduced":"1.8.37"}],"component":"psd-tools","cve_ids":["CVE-2020-10571"],"ecosystem":"PyPI","epss":0.01796,"exploited":false,"fixed_versions":["1.9.4"],"ghsa_id":"GHSA-22jr-vc7j-g762","id":"tcs_01M5KERGQ2W20SFQ1W6TNPF42V","modified_at":"2026-09-24T15:00:04.784835352Z","published_at":"2020-03-16T22:46:19Z","references":["https://osv.dev/vulnerability/GHSA-22jr-vc7j-g762","https://github.com/psd-tools/psd-tools/security/advisories/GHSA-22jr-vc7j-g762","https://nvd.nist.gov/vuln/detail/CVE-2020-10571","https://github.com/psd-tools/psd-tools/pull/198","https://github.com/psd-tools/psd-tools/commit/fd51f8b4a52bc9c1c06d1035dfdf2cd920e87074","https://github.com/psd-tools/psd-tools","https://github.com/psd-tools/psd-tools/releases/tag/v1.9.4","https://github.com/pypa/advisory-database/tree/main/vulns/psd-tools/PYSEC-2020-91.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-22jr-vc7j-g762","url":"https://osv.dev/vulnerability/GHSA-22jr-vc7j-g762"}],"summary":"Potential buffer overflow in psd-tools"}