{"action":"Upgrade phpseclib/phpseclib to 1.0.23 or later.","affected":[{"fixed":"1.0.23","introduced":"0.1.1"},{"fixed":"2.0.47","introduced":"2.0.0"},{"fixed":"3.0.36","introduced":"3.0.0"}],"component":"phpseclib/phpseclib","cve_ids":["CVE-2024-27354"],"ecosystem":"Packagist","epss":0.00601,"exploited":false,"fixed_versions":["1.0.23","2.0.47","3.0.36"],"ghsa_id":"GHSA-2528-jw5q-ww88","id":"tcs_01M5KERHBTPZM4DEC5AR9W7KNY","modified_at":"2026-05-06T18:11:13.420206Z","published_at":"2026-05-06T17:57:10Z","references":["https://osv.dev/vulnerability/GHSA-2528-jw5q-ww88","https://github.com/phpseclib/phpseclib/security/advisories/GHSA-2528-jw5q-ww88","https://nvd.nist.gov/vuln/detail/CVE-2024-27354","https://github.com/phpseclib/phpseclib/commit/2870c8fab3f132d2ed40a66c97a36fe5ab625698","https://github.com/phpseclib/phpseclib/commit/ad5dbdf2129f5e0fb644637770b7f33de8ca8575","https://github.com/phpseclib/phpseclib/commit/c55b75199ec8d12cec6eadf6da99da4a3712fe56","https://gist.github.com/katzj/ee72f3c2a00590812b2ea3c0c8890e0b","https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2024-27354.yaml","https://github.com/phpseclib/phpseclib","https://github.com/phpseclib/phpseclib/blob/master/phpseclib/Math/PrimeField.php#L49","https://lists.debian.org/debian-lts-announce/2024/03/msg00002.html","https://lists.debian.org/debian-lts-announce/2024/03/msg00003.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-2528-jw5q-ww88","url":"https://osv.dev/vulnerability/GHSA-2528-jw5q-ww88"}],"summary":"phpseclib: guardrails needed on isPrime and randomPrime"}