{"action":"Upgrade github.com/containerd/containerd to 1.6.38 or later.","affected":[{"fixed":"1.7.27","introduced":"1.7.0-beta.0"},{"fixed":"1.6.38","introduced":"0"}],"component":"github.com/containerd/containerd","cve_ids":["CVE-2024-40635"],"ecosystem":"Go","epss":0.00304,"exploited":false,"fixed_versions":["1.7.27","1.6.38"],"ghsa_id":"GHSA-265r-hfxg-fhmg","id":"tcs_01M5KERJQEJ460QQXCHA3GXMJH","modified_at":"2026-09-10T03:50:06.145474067Z","published_at":"2025-03-17T21:24:42Z","references":["https://osv.dev/vulnerability/GHSA-265r-hfxg-fhmg","https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg","https://nvd.nist.gov/vuln/detail/CVE-2024-40635","https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da","https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20","https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a","https://github.com/containerd/containerd","https://lists.debian.org/debian-lts-announce/2025/05/msg00005.html"],"severity":{"label":"medium","score":4.6},"sources":[{"source":"osv","source_id":"GHSA-265r-hfxg-fhmg#Go/github.com/containerd/containerd","url":"https://osv.dev/vulnerability/GHSA-265r-hfxg-fhmg"}],"summary":"containerd has an integer overflow in User ID handling"}