{"action":"Upgrade openssl to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0"}],"component":"openssl","cve_ids":["CVE-2016-10931"],"ecosystem":"crates.io","epss":0.00745,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-34p9-f4q3-c4r7","id":"tcs_01M5KERQ1E42CYR9HKGNQYDCFN","modified_at":"2023-11-08T03:58:21.575910Z","published_at":"2021-08-25T20:43:11Z","references":["https://osv.dev/vulnerability/GHSA-34p9-f4q3-c4r7","https://nvd.nist.gov/vuln/detail/CVE-2016-10931","https://github.com/sfackler/rust-openssl","https://github.com/sfackler/rust-openssl/releases/tag/v0.9.0","https://rustsec.org/advisories/RUSTSEC-2016-0001.html"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-34p9-f4q3-c4r7","url":"https://osv.dev/vulnerability/GHSA-34p9-f4q3-c4r7"}],"summary":"Improper Certificate Validation in openssl"}