{"action":"Upgrade apache-airflow to 2.9.0 or later.","affected":[{"fixed":"2.9.0","introduced":"2.7.0"}],"component":"apache-airflow","cve_ids":["CVE-2024-31869"],"ecosystem":"PyPI","epss":0.01058,"exploited":false,"fixed_versions":["2.9.0"],"ghsa_id":"GHSA-2522-mrjc-m688","id":"tcs_01M5KERTKY1A3EYXP871XKM7MC","modified_at":"2026-07-07T17:56:47.719774081Z","published_at":"2024-04-18T09:30:44Z","references":["https://osv.dev/vulnerability/GHSA-2522-mrjc-m688","https://nvd.nist.gov/vuln/detail/CVE-2024-31869","https://github.com/apache/airflow/pull/38795","https://github.com/apache/airflow/commit/042c2acaed7c01933d37c2f8434640ce140a4b27","https://github.com/apache/airflow","https://lists.apache.org/thread/pz6vg7wcjk901rmsgt86h76g6kfcgtk3","http://www.openwall.com/lists/oss-security/2024/04/17/10"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-2522-mrjc-m688","url":"https://osv.dev/vulnerability/GHSA-2522-mrjc-m688"}],"summary":"Apache Airflow: Sensitive configuration for providers displayed when \"non-sensitive-only\" config used"}